purebasic.info

PureBasic forum
Текущее время: Сб май 30, 2020 10:03 pm

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 90 ]  На страницу Пред.  1, 2, 3, 4, 5, 6  След.
Автор Сообщение
 Заголовок сообщения:
СообщениеДобавлено: Вс янв 22, 2012 5:54 pm 
Не в сети
профессор
Аватар пользователя

Зарегистрирован: Чт дек 17, 2009 4:49 pm
Сообщений: 1230
Откуда: г. Ангарск
Благодарил (а): 2 раз.
Поблагодарили: 17 раз.
Пункты репутации: 10
Javaca писал(а):
Разве там не было файла install.sh ? :D

Он у меня не устанавливался(я сначала скачал с гномлука), пришлось переустанавливать ubuntu(для чистоты экспиремента).

Javaca писал(а):
Не может программа не работать из-за какой-то темы или видеокарты
Дело скорее всего не в теме оформления, а в драйвере+сомпиз, проверить это не могу так как в виртуалку драйвер не установишь, а на реальное железо я по тех. причинам драйвера видеокарты не ставлю.

Javaca писал(а):
Связи Вы устанавливали с помощью purebasic_many_versions_0.3.3.deb ?
Да.

_________________
.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Вс янв 22, 2012 7:31 pm 
Не в сети
ассистент

Зарегистрирован: Вс янв 22, 2012 2:27 pm
Сообщений: 10
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Пункты репутации: 0
Удалил драйвер видеокарты, перезагрузился, результат тот же. У меня все программы работают прекрасно за исключением PureBasic 4.60. Опишите пожалуйста подробно процесс, начиная с установки связей, что Вы конкретно делаете?


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 2:43 am 
Не в сети
профессор
Аватар пользователя

Зарегистрирован: Чт дек 17, 2009 4:49 pm
Сообщений: 1230
Откуда: г. Ангарск
Благодарил (а): 2 раз.
Поблагодарили: 17 раз.
Пункты репутации: 10
Javaca
Так как воспроизвести ошибку такую же как у Вас мне неудалось, то конкретного решения данной проблемы я сказать не могу. Я не знаю уровень Вашей подготовки в линухе, поэтому давайте так:
1) если у Вас есть возможность, отрежьте кусок на диске размером 10Гб
2) установите систему на отрезанный кусок(не устанавливая ни каких дополнительных программ, не устанавливая драйверов, не включайте всякие компизы емеральды и прочую хрень, только голую систему)
3) установите тему macbuntu
4) установите пакет purebasic_many_versions_0.3.3.deb
5) создайте папку "bin" в домашней директории
6) в папку "bin" распакуйте дистрибутив пурика
7) пробуйте запустить purebasic

Если сделав всё как я написал выше в той последовательности, и особенно учитывая то, что выделено красным, у Вас не запустится пурик, то тогда нужно изискать возможность проделать всё то же самое на другом компьютере(ну или на худой конец в виртуалке). Если и в этом случае не запустится пурик, тогда я пасс.

Если же пурик запустится, тогда начинайте устанавливать необходимые Вам программы(по одной, и после завершения установки очередной программы <желательно перезагружаясь> пробуйте запустить пурик), как только пурик не запустится, напишите сюда имя программы, после установи которой перестал запускаться пурик.

P.S. Я перепробовал все версии убунт, включая Кубунту и Хубунту, подобной проблемы версиями 4.60 и 4.61b1 воспроизвести не смог :?

_________________
.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 12:16 pm 
Не в сети
ассистент

Зарегистрирован: Вс янв 22, 2012 2:27 pm
Сообщений: 10
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Пункты репутации: 0
1) Извините пожалуйста уважаемый lakomet, у меня нет времени ради одной программы заниматься мудистикой. Ни с одной программой под Линукс у меня с работоспособностью нет проблем, за исключением PureBasic 4.60

2) Если Вам поможет, то ОС ставилась Ubuntu Russian Remix 10.04 LTS (Саратовский Линукс-Центр). Затем на нее ставилась тема Macbuntu через install.sh, затем производилось обновление через "Менеджер обновлений", а потом программы.
http://www.linux-saratov.ru/download/ur ... p-i386.iso

3) На моей Ubuntu ядро Линукса - 2.6.32-37-generic, версия Gnome - 2.30.2, Compiz - 0.8.6, драйвер видео NVidia (96), IPtables - залочены все входящие соединения.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 1:01 pm 
Не в сети
профессор
Аватар пользователя

Зарегистрирован: Чт дек 17, 2009 4:49 pm
Сообщений: 1230
Откуда: г. Ангарск
Благодарил (а): 2 раз.
Поблагодарили: 17 раз.
Пункты репутации: 10
Javaca
Извинятся не за что. Я думал Вам нужно установить пурик, поэтому не имея под рукой вашего компьютера, я только предложил вариант решения данной проблемы.

_________________
.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 1:18 pm 
Не в сети
ассистент

Зарегистрирован: Вс янв 22, 2012 2:27 pm
Сообщений: 10
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Пункты репутации: 0
У меня PureBasic версии 4.51 работает нормально, а версия 4.60 не работает вообще. О чем это говорит? О том, что версия 4.60 глючная, созданная криворуким программистом, да и на оф.форуме полно тем о краше IDE включая версию 4.61 beta. Буду пользоваться пока версией 4.51.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 2:15 pm 
Не в сети
профессор
Аватар пользователя

Зарегистрирован: Чт дек 17, 2009 4:49 pm
Сообщений: 1230
Откуда: г. Ангарск
Благодарил (а): 2 раз.
Поблагодарили: 17 раз.
Пункты репутации: 10
Javaca

1) если у Вас работает 4.51 и вы хотите использовать новые плюшки из 4.60, то замените "purebasic_4.60/compilers/purebasic" файлом "purebasic_4.51/compilers/purebasic"

2) можно посмотреть содержимое Вашего "/etc/apt/sources.list"

3) если не сложно запустите программу "Меню -> Администрирование -> Средство резервного копирования"
Изображение
созданный ею файл выложите сюда(он текстовый, места много не займёт).

_________________
.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 3:28 pm 
Не в сети
ассистент

Зарегистрирован: Вс янв 22, 2012 2:27 pm
Сообщений: 10
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Пункты репутации: 0
lakomet писал(а):
1) если у Вас работает 4.51 и вы хотите использовать новые плюшки из 4.60, то замените "purebasic_4.60/compilers/purebasic" файлом "purebasic_4.51/compilers/purebasic"


Пробывал, IDE вылетает на компиляции.


lakomet писал(а):
2) можно посмотреть содержимое Вашего "/etc/apt/sources.list"


Код:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
deb http://ru.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ lucid main restricted
deb http://ru.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb http://ru.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ lucid universe
deb http://ru.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb http://ru.archive.ubuntu.com/ubuntu/ lucid multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse




lakomet писал(а):
3) если не сложно запустите программу "Меню -> Администрирование -> Средство резервного копирования"
созданный ею файл выложите сюда(он текстовый, места много не займёт).


У меня не Linux Mint установлен :) Благо это средство резервного копирования, которое Вы указали, можно установить отдельно:

sudo add-apt-repository ppa:webupd8team/mintbackup && sudo apt-get update
sudo apt-get install mintbackup


Вообщем смотрите вложение в это сообщение !!! :)


Вложения:
backup-package.list.txt [8.05 KiB]
Скачиваний: 347
Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 4:16 pm 
Не в сети
профессор
Аватар пользователя

Зарегистрирован: Чт дек 17, 2009 4:49 pm
Сообщений: 1230
Откуда: г. Ангарск
Благодарил (а): 2 раз.
Поблагодарили: 17 раз.
Пункты репутации: 10
Javaca
Я извиняюсь, совершил глупость :oops: надо было с этого начать, т.е. скачать с той раздачи. Дистрибутив выложенный там битый :evil: , он действительно не работает. Ждите когда появится другая раздача.

_________________
.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 4:21 pm 
Не в сети
МОДЕРАТОР
Аватар пользователя

Зарегистрирован: Пн апр 09, 2007 4:53 pm
Сообщений: 11648
Благодарил (а): 4 раз.
Поблагодарили: 501 раз.
lakomet писал(а):
Дистрибутив выложенный там битый
Я именно его пробовал на росинке и все нормально работает и компилирует.

_________________
Компьютер позволяет решать все те проблемы, которые до его изобретения не существовали. :) :)


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 4:37 pm 
Не в сети
профессор
Аватар пользователя

Зарегистрирован: Чт дек 17, 2009 4:49 pm
Сообщений: 1230
Откуда: г. Ангарск
Благодарил (а): 2 раз.
Поблагодарили: 17 раз.
Пункты репутации: 10
Пётр
Спорить не буду, но я ради спортивного интереса скачал демку с офа, она тоже не работает с темой macbuntu, и дистр с той раздачи не работает :? и исправленная IDE с офа не работает :(
Значит что-то помимо IDE фред исправил.

_________________
.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 4:39 pm 
Не в сети
ассистент

Зарегистрирован: Вс янв 22, 2012 2:27 pm
Сообщений: 10
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Пункты репутации: 0
lakomet, вроде нормальный дистрибутив, проблем никаких нет. :shock: Проблема только в PureBasic 4.60. На битом дистрибутиве так не бывает, всё работает, а только одна не работает. Тем более каких-либо жалоб на данный дистрибутив не поступало, работает как часы.

Уважаемый Петр, Вы возможно неправильно поняли, но lakomet вроде имел ввиду дистрибутив Ubuntu от Саратовского Линукс-центра, а не дистрибутив PureBasic 4.60 :wink:


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 4:52 pm 
Не в сети
профессор
Аватар пользователя

Зарегистрирован: Чт дек 17, 2009 4:49 pm
Сообщений: 1230
Откуда: г. Ангарск
Благодарил (а): 2 раз.
Поблагодарили: 17 раз.
Пункты репутации: 10
Javaca писал(а):
Уважаемый Петр, Вы возможно неправильно поняли

Пётр понял правильно. Выше я написал, что ни демка с офа, ни дистр пурика с раздачи на рутрекере, ни исправленная IDE с офа, не работают на вашей теме macbuntu.

А по
Javaca писал(а):
дистрибутив Ubuntu от Саратовского Линукс-центра
, то Ubuntu она и в африке Ubuntu, только для меня минт ближе, выйдет 12.04 перейду на Хubuntu.

_________________
.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 5:24 pm 
Не в сети
ассистент

Зарегистрирован: Вс янв 22, 2012 2:27 pm
Сообщений: 10
Благодарил (а): 0 раз.
Поблагодарили: 0 раз.
Пункты репутации: 0
lakomet писал(а):
Пётр понял правильно. Выше я написал, что ни демка с офа, ни дистр пурика с раздачи на рутрекере, ни исправленная IDE с офа, не работают на вашей теме macbuntu.


Проще говоря, вина криворукого разработчика PureBasic. :lol:


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн янв 23, 2012 5:36 pm 
Не в сети
профессор
Аватар пользователя

Зарегистрирован: Чт дек 17, 2009 4:49 pm
Сообщений: 1230
Откуда: г. Ангарск
Благодарил (а): 2 раз.
Поблагодарили: 17 раз.
Пункты репутации: 10
Javaca
Не ошибается тот, кто ничего не делает :wink: (фраза не моя, честно стыренная), тем более фред исправил ошибку. Просите пончика выложить обновлённый дистр пурика и всё будет работать.

_________________
.


Вернуться наверх
 Профиль  
 
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ Сообщений: 90 ]  На страницу Пред.  1, 2, 3, 4, 5, 6  След.

Часовой пояс: UTC + 3 часа


Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group (блог о phpBB)
Сборка создана CMSart Studio
Русская поддержка phpBB