purebasic.info

PureBasic forum
Текущее время: Ср июн 20, 2018 7:52 pm

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 18 ]  На страницу 1, 2  След.
Автор Сообщение
СообщениеДобавлено: Ср ноя 27, 2013 7:14 am 
Не в сети
профессор

Зарегистрирован: Чт авг 05, 2010 2:36 pm
Сообщений: 466
Откуда: Донецк
Благодарил (а): 45 раз.
Поблагодарили: 11 раз.
Кто испытывал библиотеки выпущеные для версий выпущеных до 5.20 и насколько они совместимы с последними версиями?

Выкладывайте ваши опыты, а я буду в первом посту составлять список совместимых библиотек.

У меня возникли проблемы с mp3d, окно инициализируется, показывается заголовок с системными кнопками, но окно остается пустым, хотя этот же код правильно компилится в 5.11. Проверено на : pb 5.21, mp3d 0.32a x86 для 5.11. Версия скомпиленая специально под 5.20 непроверялась.

_________________
PureBasic 5.60 X86, RfoBasic 90, Tinycc 0.97, Asus K54C Intel i7 2.7 ghz, 8 gb ddr3, Intel HD 3000, Windows XP SP3, Windows 10 x64, Nexus 4 and v5.1.1.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 9:23 am 
Не в сети
МОДЕРАТОР
Аватар пользователя

Зарегистрирован: Пн апр 09, 2007 4:53 pm
Сообщений: 11181
Благодарил (а): 4 раз.
Поблагодарили: 414 раз.
Если библиотека не предназначена для версии 5.20, то ее работа не гарантируется.
Лучше использовать версию для 5.20, тем более что она есть.

_________________
Компьютер позволяет решать все те проблемы, которые до его изобретения не существовали. :) :)


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 10:58 am 
Не в сети
МОДЕРАТОР

Зарегистрирован: Вт дек 05, 2006 8:46 am
Сообщений: 6309
Благодарил (а): 19 раз.
Поблагодарили: 188 раз.
Пункты репутации: 48
Apokalipsis писал(а):
У меня возникли проблемы с mp3d,

Может у тебя код кривой?
А если коды из папки MP3D Demos ?
Я проверил сейчас пару штук демонстрашек - работает как 3D, так и 2D на версии 5.20

_________________
read-only


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 1:22 pm 
Не в сети
профессор

Зарегистрирован: Чт авг 05, 2010 2:36 pm
Сообщений: 466
Откуда: Донецк
Благодарил (а): 45 раз.
Поблагодарили: 11 раз.
Пётр писал(а):
Если библиотека не предназначена для версии 5.20, то ее работа не гарантируется.
Лучше использовать версию для 5.20, тем более что она есть.

А как тогда быть если под данную версию компилятора эта библиотека не перекомпилирована?
Например disphelper.

kvitaliy писал(а):
Apokalipsis писал(а):
У меня возникли проблемы с mp3d,

Может у тебя код кривой?
А если коды из папки MP3D Demos ?
Я проверил сейчас пару штук демонстрашек - работает как 3D, так и 2D на версии 5.20

Mpmusicplayer компилится как я писал выше.
Еще потестировав simpleoop нашел баг, в нескольких примерах выдает ошибку синтаксиса, при чем в строках где все идеально и это на родных примерах а не лично написаных. Свое пока не проверял.

_________________
PureBasic 5.60 X86, RfoBasic 90, Tinycc 0.97, Asus K54C Intel i7 2.7 ghz, 8 gb ddr3, Intel HD 3000, Windows XP SP3, Windows 10 x64, Nexus 4 and v5.1.1.


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 1:30 pm 
Не в сети
МОДЕРАТОР
Аватар пользователя

Зарегистрирован: Пн апр 09, 2007 4:53 pm
Сообщений: 11181
Благодарил (а): 4 раз.
Поблагодарили: 414 раз.
Apokalipsis писал(а):
Например disphelper.
Ее исходники в сети и их можно перекомпилировать под требуемую версию. Или подключать исходник к проекту с помощью XincludeFile.

_________________
Компьютер позволяет решать все те проблемы, которые до его изобретения не существовали. :) :)


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 6:05 pm 
Не в сети
ассистент

Зарегистрирован: Пт фев 22, 2013 3:29 pm
Сообщений: 18
Благодарил (а): 0 раз.
Поблагодарили: 2 раз.
Пункты репутации: 0
MP3d Версия для 5.20 работает на 5.21
Не смог запустить только примеры с тенями и шейдеры не запускаются


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 6:19 pm 
Не в сети
МОДЕРАТОР
Аватар пользователя

Зарегистрирован: Пн апр 09, 2007 4:53 pm
Сообщений: 11181
Благодарил (а): 4 раз.
Поблагодарили: 414 раз.
Apokalipsis писал(а):
Версия скомпиленая специально под 5.20 непроверялась.
То есть в PB 5.21 нормально компилируется код, использующий библиотеку от предыдущей версии?
Не может быть такого. Появляется ошибка.
Цитата:
Следующая PureLibrary отсутствует: Misc.

_________________
Компьютер позволяет решать все те проблемы, которые до его изобретения не существовали. :) :)


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 7:10 pm 
Не в сети
МОДЕРАТОР

Зарегистрирован: Вт дек 05, 2006 8:46 am
Сообщений: 6309
Благодарил (а): 19 раз.
Поблагодарили: 188 раз.
Пункты репутации: 48
Пётр писал(а):
Не может быть такого. Появляется ошибка.
Цитата:
Следующая PureLibrary отсутствует: Misc.

Да действительно есть такая.
P.S.
Да ты лично себе лицензию купил? Поздравляю!

_________________
read-only


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 7:14 pm 
Не в сети
МОДЕРАТОР
Аватар пользователя

Зарегистрирован: Пн апр 09, 2007 4:53 pm
Сообщений: 11181
Благодарил (а): 4 раз.
Поблагодарили: 414 раз.
Я тестил в 5.20, но в 5.21 будет та же ошибка. Это уже проверено на предыдущих x.x1 версиях, в которых только исправляют ошибки.

_________________
Компьютер позволяет решать все те проблемы, которые до его изобретения не существовали. :) :)


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 7:34 pm 
Не в сети
МОДЕРАТОР

Зарегистрирован: Вт дек 05, 2006 8:46 am
Сообщений: 6309
Благодарил (а): 19 раз.
Поблагодарили: 188 раз.
Пункты репутации: 48
Пётр писал(а):
Я тестил в 5.20, но в 5.21 будет та же ошибка. Это уже проверено на предыдущих x.x1 версиях, в которых только исправляют ошибки.

Тоже так думал, оказалось нет
в 520
Изображение
в 521 скопировал ту же либу
Изображение
файл то же одинаковый запускаю

_________________
read-only


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 9:34 pm 
Не в сети
МОДЕРАТОР
Аватар пользователя

Зарегистрирован: Пн апр 09, 2007 4:53 pm
Сообщений: 11181
Благодарил (а): 4 раз.
Поблагодарили: 414 раз.
Виталий какой дистрибутив либы ставишь?
Этот, со странички не работает на PB 5.20 сообщая об ошибке отсутствия библиотеки Misc.
Работает только с этой либой.

_________________
Компьютер позволяет решать все те проблемы, которые до его изобретения не существовали. :) :)


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 10:16 pm 
Не в сети
МОДЕРАТОР

Зарегистрирован: Вт дек 05, 2006 8:46 am
Сообщений: 6309
Благодарил (а): 19 раз.
Поблагодарили: 188 раз.
Пункты репутации: 48
Честно сказать не знаю. Уже всё перепуталось. Но судя по дате от 22.06.2013. Хотя и не факт, дата могла и измениться при разных манипуляциях.
Но поставил тот, что по твоей ссылке из zip - нормально работает с 521

_________________
read-only


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср ноя 27, 2013 10:21 pm 
Не в сети
МОДЕРАТОР
Аватар пользователя

Зарегистрирован: Пн апр 09, 2007 4:53 pm
Сообщений: 11181
Благодарил (а): 4 раз.
Поблагодарили: 414 раз.
Тот что в архиве это для 5.20. Речь идет о том что в exe. Либа из него не работает в 5.20.
Кстати, рассылка текущей версии была, или я что-то пропустил?

_________________
Компьютер позволяет решать все те проблемы, которые до его изобретения не существовали. :) :)


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Чт ноя 28, 2013 6:20 am 
Не в сети
МОДЕРАТОР

Зарегистрирован: Вт дек 05, 2006 8:46 am
Сообщений: 6309
Благодарил (а): 19 раз.
Поблагодарили: 188 раз.
Пункты репутации: 48
Пётр писал(а):
Кстати, рассылка текущей версии была, или я что-то пропустил?

Оповещение было сделано, но заказал только 1 человек, остальные отказались ( кто отписался в ответ).
Но заказывать можно всегда, без напоминаний.
.

_________________
read-only


Вернуться наверх
 Профиль  
 
СообщениеДобавлено: Ср июн 01, 2016 9:48 am 
Не в сети
профессор

Зарегистрирован: Ср янв 14, 2009 4:12 pm
Сообщений: 2002
Благодарил (а): 12 раз.
Поблагодарили: 101 раз.
Пункты репутации: 43
Есть старый проект. В PB 5.30 компилируется, а в 5.42 уже не хочет
Ошибка
---------------------------
PureBasic - Linker error
---------------------------
POLINK: error: Unresolved external symbol '_SYS_CopyString'.
POLINK: fatal error: 1 unresolved external(s).
---------------------------
ОК
---------------------------

Номер строки с ошибкой не показывает (Purifier включен)
99% это из за Droopy или PBOSL. Может есть "хитрый способ найти все вызовы этих библ" чтобы избавиться от них
Просматривать весь код - не вариант ибо > 10000 строчек

_________________
Всё должно быть просто, настолько просто, насколько возможно, но не проще. (c) Альберт Эйнштейн
Изображение


Вернуться наверх
 Профиль  
 
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ Сообщений: 18 ]  На страницу 1, 2  След.

Часовой пояс: UTC + 3 часа


Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Создано на основе phpBB® Forum Software © phpBB Group (блог о phpBB)
Сборка создана CMSart Studio
Русская поддержка phpBB